Menu

QASymphony Support Browser Requirements

As of June 14, 2018, you must use a modern browser version that supports TLS version 1.2 or above to continue to securely access the QASymphony Support Site. 

What does this mean for you?

If you are not using one of the minimum browser versions listed below, you will be required to upgrade your browser to connect to the desktop or mobile web versions of the QASymphony Support site:

Internet Explore Edge Firefox Chrome Safari iOS Safari Opera Mini Chrome for Android UC Browser for Android Samsung Internet
11 12+ 27+ 30+ 7+ 7+​​ 17+ 30+ 11.8 4, 6.2
Powered by Zendesk